[svn:parrot] r36391 - trunk/src/gc

whiteknight at svn.parrot.org whiteknight at svn.parrot.org
Fri Feb 6 00:48:23 UTC 2009


Author: whiteknight
Date: Fri Feb  6 00:48:22 2009
New Revision: 36391
URL: https://trac.parrot.org/parrot/changeset/36391

Log:
[GC] use PObj* instead of void* for readability. particle++

Modified:
   trunk/src/gc/gc_private.h

Modified: trunk/src/gc/gc_private.h
==============================================================================
--- trunk/src/gc/gc_private.h	Fri Feb  6 00:33:15 2009	(r36390)
+++ trunk/src/gc/gc_private.h	Fri Feb  6 00:48:22 2009	(r36391)
@@ -34,13 +34,13 @@
 /* We're using this here to add an additional pointer to a PObj without
    having to actually add an entire pointer to every PObj-alike structure
    in Parrot. Astute observers may notice that if the PObj is comprised of
-   only an INTVAL, then there are some systems where sizeof(void*) can be
+   only an INTVAL, then there are some systems where sizeof(PObj*) can be
    larger then sizeof(PObj), thus creating overflow. However PObjs are never
    used by themselves, things like PMCs and STRINGs are cast to PObj in the
-   GC, so we should have plenty of space. */ 
+   GC, so we should have plenty of space. */
 typedef union GC_MS_PObj_Wrapper {
     PObj obj;
-    void *next_ptr;
+    PObj *next_ptr;
 } GC_MS_PObj_Wrapper;
 
 /* HEADERIZER BEGIN: src/gc/system.c */


More information about the parrot-commits mailing list