[svn:parrot] r43740 - trunk/ports/debian

allison at svn.parrot.org allison at svn.parrot.org
Sun Feb 7 05:03:18 UTC 2010


Author: allison
Date: Sun Feb  7 05:03:18 2010
New Revision: 43740
URL: https://trac.parrot.org/parrot/changeset/43740

Log:
[debian] Adding ${misc:Depends} to all binary packages, as requested
by lintian check.

Modified:
   trunk/ports/debian/control.in

Modified: trunk/ports/debian/control.in
==============================================================================
--- trunk/ports/debian/control.in	Sun Feb  7 04:56:46 2010	(r43739)
+++ trunk/ports/debian/control.in	Sun Feb  7 05:03:18 2010	(r43740)
@@ -8,7 +8,7 @@
 
 Package: parrot
 Architecture: any
-Depends: ${shlibs:Depends}, parrot-minimal (= ${binary:Version})
+Depends: ${shlibs:Depends}, ${misc:Depends}, parrot-minimal (= ${binary:Version})
 Suggests: parrot-doc
 Provides: parrot-test, parrot-data-dumper
 Description: A virtual machine for dynamic languages
@@ -18,7 +18,7 @@
 
 Package: parrot-minimal
 Architecture: any
-Depends: ${shlibs:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
 Conflicts: parrot ( << 1.0.0 )
 Replaces: parrot ( << 1.0.0 )
 Description: A minimal install of the Parrot VM
@@ -29,7 +29,7 @@
 Package: libparrot at SOVERSION@
 Architecture: any
 Section: libs
-Depends: ${shlibs:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
 Description: Parrot shared library
  This package contains the Parrot shared library, used by the Parrot virtual
  machine and by programs that embed Parrot.
@@ -37,7 +37,7 @@
 Package: libparrot-dev
 Architecture: any
 Section: libdevel
-Depends: libparrot at SOVERSION@ (= ${binary:Version}), parrot
+Depends: ${misc:Depends}, libparrot at SOVERSION@ (= ${binary:Version}), parrot
 Description: Parrot shared library development files
  This package contains header files and a static library, needed to develop
  applications which embed Parrot.
@@ -46,6 +46,7 @@
 Architecture: all
 Section: doc
 Suggests: perl-doc
+Depends: ${misc:Depends}
 Description: Parrot documentation
  Parrot manual pages and raw Pod documentation. If you are developing a
  compiler or extensions for Parrot, you will need this. If you're only using a
@@ -54,7 +55,7 @@
 Package: parrot-devel
 Architecture: any
 Section: devel
-Depends: ${shlibs:Depends}, parrot, libparrot-dev, perl
+Depends: ${shlibs:Depends}, ${misc:Depends}, parrot, libparrot-dev, perl
 Provides: parrot-pge, parrot-tge, parrot-pct, parrot-nqp
 Conflicts: parrot ( << 1.0.0 ), libparrot-dev ( << 1.0.0 )
 Replaces: parrot ( << 1.0.0 ), libparrot-dev ( << 1.0.0 )


More information about the parrot-commits mailing list